Details about  Very Vintage Apple Macintosh Hypercard version 1.2.5 Package... 3-1/2" floppies

See original listing
Very Vintage Apple Macintosh Hypercard version 1.2.5 Package... 3-1/2" floppies
Very-Vintage-Apple-Macintosh-Hypercard-version-1-2-5-Package-3-1-2-034-floppies
Item Sold
Condition:
--not specified

very old Macintosh software - tested to install and run.

Ended:
Dec 07, 2019
Price:
US $35.00
Shipping:
FREE Economy Shipping See details
Item location:
Elbridge, New York, United States