Skip to main content

Visioneer Strobe XP100 for Use With Windows XP / 2000 / Me / 98SE

  • $24.99
  • Buy It Now
  • Free Shipping
View Details
Compatible with Windows XP / 2000 / Me / 98SE ONLY from what the website says but I'd bet it could be used in compatibility mode with newer versions of Windows. No Exceptions. Sorry no U.S. territorie...
Condition:New: Other (see details)
Time left:10d 9h 4m
Item location:Florida
Sold by:
This item is being sold by eBay Top rated seller.